We are currently using R3/46C with  SAP GUI version 640. When we upgrade to ECC 6.0 with SAP GUI version 710, will we have to install a new GuiXT version for the new configuration?

An appropriate GuiXT version is automatically installed with the SAP GUI patch. Please use SAP GUI PL3 or upwards, and GuiXT version 2007 Q3 2 or upwards.