We are upgrading to MySAP ERP 2005. Will GuiXT still work? Are there any issues we need to take into account, please?

You can indeed use GuiXT for MySAP ERP2005 as well. There are no changes in script syntax or functionality. If you use sapgui 6.40, please install a 2006 version of GuiXT.